Quando você entrar em WHM você vê esta mensagem?

 

” A última tentativa para atualizar cPanel & WHM foi Bloqueado “

 

 

 

cpanel-blocked1

 

Por que a atualização WHM Bloqueado?

WHM melhoramentos podem ser bloqueados por um número de razões:

  • Falta de espaço em disco.
  • Licença inválida.
  • Leia somente sistemas de arquivos.
  • Problemas de integridade do banco de dados rpm.
  • Conflitos Plugin
  • Versão MySQL

Qualquer destas questões pode bloquear uma atualização. Para ver por que a atualização foi bloqueada, basta clicar no link detalhes na mensagem:

blocked2

 

 

Nos detalhes, podemos ver que WHM foi bloqueado

MySQL Atualização

Recentemente, temos visto um crescente número de servidores com a atualização WHM bloqueado erro devido ao MySQL. A maioria dos sistemas, especialmente CentOS e Red Hat 5 e anteriores, terá MySQL 5.0 instalado por padrão. No Red Hat ou CentOS 6, você pode ter MySQL 5.1 instalado por padrão.

WHM gerencia as versões do MySQL para você. Você pode atualizar facilmente a partir do painel de controle:

mysqlup

 

MySQL Atualização Atenção

Antes de atualizar o MySQL para resolver o erro de atualização WHM bloqueado, há algumas coisas que você deve considerar:

  • Você não pode fazer o downgrade (facilmente) a uma versão anterior do MySQL.
  • WHM / cPanel não backup de seus dados antes da atualização.
  • A atualização pode requerer PHP / Apache para ser reconstruído.
  • Você precisa verificar se seus aplicativos podem usar o MySQL 5.5.

Antes de atualizar o MySQL para resolver o erro de atualização WHM bloqueado, há algumas coisas que você deve considerar:

  • Você não pode fazer o downgrade (facilmente) a uma versão anterior do MySQL.
  • WHM / cPanel não backup de seus dados antes da atualização.
  • A atualização pode requerer PHP / Apache para ser reconstruído.
  • Você precisa verificar se seus aplicativos podem usar o MySQL 5.5.

Estes são apenas alguns dos itens a serem considerados antes de fazer o upgrade. Embora o MySQL 5.1 para o MySQL 5.5 pode não parecer um grande lançamento, havia várias diferenças importantes introduzidas no MySQL 5.5. MySQL tem documentação sobre mudanças incompatíveis .

A grande mudança é que o InnoDB se torna o mecanismo de armazenamento padrão no MySQL 5.5.Se você criar um banco de dados e não especificar um mecanismo de armazenamento, tabelas serão criadas com InnoDB em vez de tabelas MyISAM. Isso pode causar problemas de recuperação em sistemas de hospedagem compartilhada, uma vez para restaurar um único banco de dados, você tem que restaurar todo o sistema de dados do InnoDB.

Reconstruindo Apache / PHP

Durante o processo de atualização, o Apache eo PHP precisará ser reconstruído. Eu vi o atualizador deixar de reconhecer que a reconstrução bem-sucedida. Se você tiver um problema, você pode, então, tentar reconstruir Apache via WHM ou na linha de comando.

 

Atualizando WHM

Uma vez que você atualizar o MySQL, então você pode voltar e atualizar WHM. O processo deve terminar agora sem erros.

 

suporte qtag

Deixe uma resposta

O seu endereço de email não será publicado Campos obrigatórios são marcados *

2 × um =